archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-wayland / repos / extra-x86_64 / PKGBUILD
blob563404b77aedc55318a61f06d8e87635b6aa9516
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-wayland
6 _qtver=6.5.0
7 pkgver=${_qtver/-/}
8 pkgrel=2
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Provides APIs for Wayland'
13 depends=(qt6-declarative libxcomposite)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('ccc57fa277fc5f1c1c2c4733eae80a60996b67a067233c47809e542aa31759a3')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja \
22     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname