1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients'
12 depends=(qt6-declarative)
13 makedepends=(cmake ninja qt6-websockets)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('d9553d646df3681b8e09c7609bf7eda0cde69b562f180fa50451a987ed00f1bf')
20 cmake -B build -S $_pkgfn -G Ninja \
21 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
26 DESTDIR="$pkgdir" cmake --install build
28 install -d "$pkgdir"/usr/share/licenses
29 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname