1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: Andreas Radke <andyrtr@archlinux.org>
4 # Contributor: eric <eric@archlinux.org>
5 # Contributor: Damir Perisa <damir.perisa@bluewin.ch>
11 pkgdesc="A C library that parses RDF/XML/N-Triples into RDF triples"
13 url="https://librdf.org/raptor"
14 license=(Apache GPL2 LGPL2.1)
15 depends=(glibc libxml2 libxslt xz zlib)
16 makedepends=(curl gtk-doc icu)
17 provides=(libraptor2.so)
18 source=(https://librdf.org/dist/source/$_name-$pkgver.tar.gz{,.asc})
19 sha512sums=('9bd5cff36390e1e0ef15ac56e5413ecfceb4018cb531a4da8850d3623615f12a93690a78be61f9d9ae7a24e16f6446e356bc2b7f34051ddc077761d85a9b7c44'
21 b2sums=('1e5e5742ba4cdaacb98a9ba77a9352589df0da60869e7721ee140c81ed4886bf909b37b247bd925c82a4ac44b3c11a909c913f0851d49a1d9d91c9293189266d'
23 validpgpkeys=('F879F0DEDA780198DD08DC6443EC92504F71955A') # Dave Beckett <dave@dajobe.org>
31 local configure_options=(
34 --with-icu-config=/usr/bin/icu-config
38 ./configure "${configure_options[@]}"
39 # prevent excessive overlinking due to libtool
40 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
45 # run with one job as tests are otherwise flaky: https://github.com/dajobe/raptor/issues/49
46 make check -C $_name-$pkgver -j1
55 make DESTDIR="$pkgdir" install -C $_name-$pkgver
56 install -vDm 644 $_name-$pkgver/{AUTHORS,ChangeLog*,README} -t "$pkgdir/usr/share/doc/$pkgname/"