archrelease: copy trunk to extra-x86_64
[arch-packages.git] / rhash / repos / extra-x86_64 / PKGBUILD
blob9e29b6985a0f6e619a5e9c96d2ebe3a9daeeab81
1 # Maintainer: Johannes Löthberg <johannes@kyriasis.com>
2 # Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
3 # Contributor: 謝致邦 <Yeking@Red54.com>
4 # Contributor: cantabile <cantabile dot desu at gmail dot com>
5 # Contributor: reMiND <detanator@gmail.com>
7 pkgname=rhash
8 pkgver=1.4.3
9 pkgrel=1
11 pkgdesc='Utility for verifying hash sums of files'
12 url='https://github.com/rhash/RHash'
13 license=('BSD')
14 arch=('x86_64')
16 depends=('glibc')
18 backup=('etc/rhashrc')
20 source=(rhash-$pkgver.tar.gz::https://github.com/rhash/RHash/archive/v$pkgver.tar.gz
21         rhash-$pkgver.tar.gz.asc::https://github.com/rhash/RHash/releases/download/v$pkgver/v$pkgver.tar.gz.asc)
23 sha512sums=('d87ffcde28d8f25cf775c279fed457e52d24523ed9b695629dae694b3c22372247d18f6032f8ce13a0b70fa2953be408982e46659daaa7c4ab227ae89eaed9c7'
24             'SKIP')
25 # https://sourceforge.net/p/rhash/wiki/PublicKey/
26 validpgpkeys=('2875F6B1C2D27A4F0C8AF60B2A714497E37363AE')
28 prepare() {
29   cd RHash-$pkgver
30   ./configure --prefix=/usr --sysconfdir=/etc --extra-cflags="$CFLAGS" --extra-ldflags="$LDFLAGS"
33 build() {
34   cd RHash-$pkgver
35   make
38 check() {
39   cd RHash-$pkgver
40   make test test-lib
43 package() {
44   cd RHash-$pkgver
46   # program
47   make DESTDIR="$pkgdir" install
49   # library, since the makefiles are still broken
50   make -C librhash DESTDIR="$pkgdir" install-lib-headers install-lib-shared install-so-link
52   # license
53   install -Dm644 COPYING "$pkgdir"/usr/share/licenses/rhash/LICENSE