archrelease: copy trunk to extra-x86_64
[arch-packages.git] / rtmpdump / trunk / PKGBUILD
blob539151acd6f54d08236618876d057183db20d605
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: xduugu
4 # Contributor: Elis Hughes <elishughes@googlemail.com>
6 pkgname=rtmpdump
7 pkgver=2.4.r99.f1b83c1
8 pkgrel=2
9 epoch=1
10 pkgdesc='A toolkit for RTMP streams'
11 arch=(x86_64)
12 url=https://rtmpdump.mplayerhq.hu/
13 license=(
14   GPL2
15   LGPL2.1
17 depends=(
18   glibc
19   gnutls
20   zlib
22 makedepends=(git)
23 provides=(librtmp.so)
24 #options=('!makeflags')
25 _commit=f1b83c10d8beb43fcc70a6e88cf4325499f25857
26 source=(git+https://git.ffmpeg.org/rtmpdump#commit=${_commit})
27 sha256sums=(SKIP)
29 pkgver() {
30   cd rtmpdump
31   echo "2.4.r$(git rev-list --count c28f1bab7822de97353849e7787b59e50bbb1428..HEAD).$(git rev-parse --short HEAD)"
34 build() {
35   cd rtmpdump
36   sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
37   make \
38     OPT="$CFLAGS" \
39     XLDFLAGS="$LDFLAGS"
42 package() {
43   cd rtmpdump
44   make \
45     prefix=/usr \
46     sbindir=/usr/bin \
47     mandir=/usr/share/man \
48     DESTDIR="${pkgdir}" \
49     install
52 # vim: ts=2 sw=2 et: