archrelease: copy trunk to extra-x86_64
[arch-packages.git] / seahorse-nautilus / repos / extra-x86_64 / PKGBUILD
blob7da3570f41d15bacb406a91101f47c663b74b180
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
4 pkgname=seahorse-nautilus
5 pkgver=3.11.92+r96+g0fd324c
6 pkgrel=1
7 epoch=1
8 pkgdesc="PGP encryption and signing for nautilus"
9 url="https://gitlab.gnome.org/GNOME/seahorse-nautilus"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(libnautilus-extension gtk3 gcr libcryptui libnotify)
13 makedepends=(meson git)
14 options=(debug)
15 _commit=0fd324c191565bff76ca45a01b2da14b4ab7b3bd  # master
16 source=("git+$url.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 package() {
34   depends+=(libnautilus-extension.so)
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: