archrelease: copy trunk to extra-x86_64
[arch-packages.git] / sip / trunk / PKGBUILD
blobcddac231cb014826445feb1599e19ded977617ca
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=sip
4 pkgver=6.7.9
5 pkgrel=2
6 arch=(x86_64)
7 pkgdesc='A tool that makes it easy to create Python bindings for C and C++ libraries'
8 url='https://www.riverbankcomputing.com/software/sip/intro'
9 license=('custom:"sip"')
10 depends=(python-toml python-packaging python-setuptools python-ply)
11 makedepends=(python-build python-installer python-wheel)
12 source=(https://pypi.python.org/packages/source/s/sip/$pkgname-$pkgver.tar.gz)
13 sha256sums=('35d51fc10f599d3696abb50f29d068ad04763df7b77808c76b74597660f99b17')
15 build() {
16   cd $pkgname-$pkgver
17   python -m build --wheel --no-isolation
20 package() {
21   cd $pkgname-$pkgver
22   python -m installer --destdir="$pkgdir" dist/*.whl