archrelease: copy trunk to extra-x86_64
[arch-packages.git] / svt-av1 / trunk / PKGBUILD
blob01ff0c196f5d44718b67a378ce645e0e3eb539c2
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Daniel Bermond <dbermond@archlinux.org>
3 # Contributor: Thomas Schneider <maxmusterm@gmail.com>
5 pkgname=svt-av1
6 pkgver=1.5.0
7 pkgrel=1
8 pkgdesc='Scalable Video Technology AV1 encoder and decoder'
9 arch=(x86_64)
10 url=https://gitlab.com/AOMediaCodec/SVT-AV1
11 license=(
12   BSD
13   'custom: Alliance for Open Media Patent License 1.0'
15 depends=(glibc)
16 makedepends=(
17   cmake
18   git
19   nasm
20   ninja
22 _tag=ea296ef350714fb6f105b420fb0bc321d9997ffd
23 source=(git+https://gitlab.com/AOMediaCodec/SVT-AV1.git#tag=${_tag})
24 b2sums=(SKIP)
26 prepare() {
27   sed '/CMAKE_BUILD_TYPE Release/d' -i SVT-AV1/CMakeLists.txt
30 pkgver() {
31   cd SVT-AV1
32   git describe --tags | sed 's/^v//'
35 build() {
36   export LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
37   cmake -S SVT-AV1 -B build -G Ninja \
38     -DCMAKE_INSTALL_PREFIX=/usr \
39     -DBUILD_SHARED_LIBS=ON \
40     -DNATIVE=OFF
41   ninja -C build
44 package() {
45   DESTDIR="${pkgdir}" ninja -C build install
46   install -Dm 644 SVT-AV1/{LICENSE,PATENTS}.md -t "${pkgdir}"/usr/share/licenses/svt-av1/
49 # vim: ts=2 sw=2 et: