archrelease: copy trunk to extra-x86_64
[arch-packages.git] / swell-foop / repos / extra-x86_64 / PKGBUILD
blob2f1fa15e6a14bf55fcfb3c7a0d146b9f3cdd2659
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=swell-foop
5 pkgver=41.1
6 pkgrel=1
7 pkgdesc="Clear the screen by removing groups of colored and shaped tiles"
8 url="https://wiki.gnome.org/Apps/Swell%20Foop"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(clutter-gtk librsvg libgnome-games-support libgee)
12 makedepends=(yelp-tools appstream-glib vala git meson)
13 groups=(gnome-extra)
14 options=(debug)
15 _commit=f89d9cfe7c4b73ae37cf5ed0a6bdc9060365e55d  # tags/41.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/swell-foop.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"