archrelease: copy trunk to extra-x86_64
[arch-packages.git] / syntax-highlighting / trunk / PKGBUILD
blobd2f63dece22fce3c3ee6b6da627e3186e46794fc
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=syntax-highlighting
5 pkgver=5.106.0
6 pkgrel=1
7 pkgdesc='Syntax highlighting engine for structured text and code'
8 arch=(x86_64)
9 url='https://community.kde.org/Frameworks'
10 license=(GPL2)
11 depends=(qt5-base)
12 makedepends=(extra-cmake-modules qt5-declarative qt5-xmlpatterns qt5-tools qt5-doc doxygen)
13 optdepends=('qt5-declarative: QML bindings')
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('cd80e3a3bb541f8337e9b29deeabd8545959a02ba1ed9384fb7e8dd7819b1c05'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF \
23     -DQRC_SYNTAX=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build