1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=system-config-printer
7 pkgdesc="A CUPS printer configuration tool and status applet"
8 url="https://github.com/OpenPrinting/system-config-printer"
11 depends=('python-pycups' 'python-dbus' 'python-pycurl' 'libnotify'
12 'python-gobject' 'gtk3' 'python-cairo' 'libusb')
13 makedepends=('xmlto' 'docbook-xsl' 'desktop-file-utils' 'libsecret')
14 optdepends=('libsecret: password management'
15 'python-pysmbc: SMB browser support'
16 'cups-pk-helper: PolicyKit helper to configure cups with fine-grained privileges')
17 source=(https://github.com/OpenPrinting/system-config-printer/releases/download/v${pkgver}/system-config-printer-${pkgver}.tar.xz{,.asc})
18 sha256sums=('b1a69e1b4ec2add569a87aeca811a37c5361ee6ae327ec852b79e64223e34bee'
20 validpgpkeys=('7082A0A50A2E92640F3880E0E4522DCC9B246FF7') # Zdenek Dohnal (The old 4D4227D7 key revoked) <zdohnal@redhat.com>
23 cd ${pkgname}-${pkgver}
25 ./configure --prefix=/usr \
28 --with-systemdsystemunitdir=/usr/lib/systemd/system \
29 --with-udevdir=/usr/lib/udev \
31 --with-cups-serverbin-dir=/usr/lib/cups
36 cd ${pkgname}-${pkgver}
37 make DESTDIR="$pkgdir" install
40 find "$pkgdir" -name '*.py' -exec python -mpy_compile {} +
42 find "$pkgdir" -name '*.py' -exec python -O -mpy_compile {} +
44 # fix dbus policy location
45 install -dm755 "$pkgdir"/usr/share/dbus-1/system.d
46 mv "$pkgdir"/etc/dbus-1/system.d/* "$pkgdir"/usr/share/dbus-1/system.d
47 rm -rf "$pkgdir"/etc/dbus-1