archrelease: copy trunk to extra-x86_64
[arch-packages.git] / telepathy-kde-integration-module / repos / extra-x86_64 / PKGBUILD
blob1eb0776d977f898e6621ffe305a734dc00cd6b8b
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Laurent Carlier <lordheavym@gmail.com>
5 pkgname=telepathy-kde-integration-module
6 _pkgname=ktp-kded-module
7 pkgver=23.04.1
8 pkgrel=1
9 pkgdesc='Sits in KDED and takes care of various bits of system integration like setting user to auto-away or handling connection errors'
10 arch=(x86_64)
11 url='https://community.kde.org/KTp'
12 license=(GPL)
13 groups=(kde-applications kde-network telepathy-kde)
14 depends=(telepathy-kde-common-internals kidletime kactivities)
15 makedepends=(extra-cmake-modules kdoctools)
16 source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('77c5c9d39295d21c13fdc5d5f8d60671381c84a7b790a71f0709b4cb7df9798c'
18             'SKIP')
19 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
20               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
21               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
23 build() {
24   cmake -B build -S $_pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build