archrelease: copy trunk to extra-x86_64
[arch-packages.git] / telepathy-logger / trunk / PKGBUILD
blob1b56191f2c2ca4f6896c08fccc67c9e1fb5e51e4
1 # Maintainer: Ionut Biru <ibiru@archlinux.org>
2 pkgname=telepathy-logger
3 pkgver=0.8.2
4 pkgrel=5
5 pkgdesc="Telepathy framework logging daemon"
6 arch=(x86_64)
7 url="http://telepathy.freedesktop.org/wiki/Logger"
8 license=('LGPL2.1')
9 depends=('telepathy-glib' 'sqlite' 'libxml2' 'dconf')
10 makedepends=('intltool' 'gobject-introspection' 'libxslt' 'python')
11 source=(https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2{,.asc}
12         0001-tools-Fix-the-build-with-Python-3.patch)
13 sha256sums=('8fcad534d653b1b365132c5b158adae947810ffbae9843f72dd1797966415dae'
14             'SKIP'
15             'd94899bed85a4ac90158838524d16c761956eec2cd0d223b6a18bffa09ec008b')
16 validpgpkeys=('5113B855236702158C41C366432705FACDD40325')
18 prepare() {
19   cd "$pkgname-$pkgver"
20   # fix build with python3
21   patch -Np1 -i ../0001-tools-Fix-the-build-with-Python-3.patch
24 build() {
25   cd "$pkgname-$pkgver"
27   ./configure --prefix=/usr \
28     --sysconfdir=/etc \
29     --libexecdir=/usr/lib/telepathy \
30     --enable-call \
31     --disable-static \
32     --disable-scrollkeeper \
33     --disable-schemas-compile
34   make
37 package() {
38   cd "$pkgname-$pkgver"
39   make DESTDIR="$pkgdir/" install
42 # vim:set ts=2 sw=2 et: