archrelease: copy trunk to extra-x86_64
[arch-packages.git] / texinfo / trunk / PKGBUILD
blob371986fb6e37118bf98096e748ddb2b58ee86249
1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
6 pkgname=texinfo
7 pkgver=7.0.3
8 pkgrel=1
9 pkgdesc='GNU documentation system for on-line information and printed output'
10 arch=(x86_64)
11 url='https://www.gnu.org/software/texinfo/'
12 license=(GPL3)
13 depends=(ncurses gzip perl sh)
14 optdepends=('perl-archive-zip: EPUB file output via texi2any')
15 source=(https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
16         texinfo-install.hook
17         texinfo-remove.hook)
18 sha256sums=('74b420d09d7f528e84f97aa330f0dd69a98a6053e7a4e01767eed115038807bf'
19             'SKIP'
20             '5409fc3aa8a35e8f3d901e96bc50c986f204d90ce6bface0a7d79d99b487f801'
21             '913ca8aac84386399b0a83ed0f6b04b5e6322da62f5c1d7ed31e1050ed37c1a9')
22 validpgpkeys=('EAF669B31E31E1DECBD11513DDBC579DAB37FBA9') # Gavin Smith
24 build() {
25   cd $pkgname-$pkgver
26   ./configure --prefix=/usr
27   make
30 check() {
31   make -C $pkgname-$pkgver check
34 package() {
35   make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
37   install -dm755 "$pkgdir"/usr/share/libalpm/hooks/
38   install -m644 texinfo-{install,remove}.hook "$pkgdir"/usr/share/libalpm/hooks/