1 # Maintainer: Firmicus <firmicus āt gmx dōt net>
2 # Maintainer: Rémy Oudompheng <remy@archlinux.org>
8 pkgdesc="TeX Live - Music typesetting packages"
11 depends=('texlive-core')
12 optdepends=('python: for scripts from the lilyglyphs packages'
13 'fontforge: for scripts from the lilyglyphs packages')
14 groups=('texlive-most')
15 url='http://tug.org/texlive/'
16 source=("https://sources.archlinux.org/other/texlive/$pkgname-$pkgver-src.zip" "$pkgname.maps")
17 options=('!emptydirs')
18 sha256sums=('83df527875cd6bb77941868f35cdc0b7b7300f25c1644fe702ded855e7f492f9'
19 '0b3cc045390e756eb9243c0acc99a48a9c02ddab4764f4a00f8c3170660f017f')
25 rm -rf {tlpkg,doc,source} || true
29 install -m755 -d "$pkgdir"/var/lib/texmf/arch/installedpkgs
30 sed -i '/^#/d' CONTENTS
31 install -m644 CONTENTS "$pkgdir"/var/lib/texmf/arch/installedpkgs/${pkgname}_${_revnr}.pkgs
32 install -m644 $pkgname.maps "$pkgdir"/var/lib/texmf/arch/installedpkgs/
33 install -m755 -d "$pkgdir"/usr/share
34 wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && echo $d; done) || true
35 for dir in $wanteddirs; do
36 find $dir -type d -exec install -d -m755 "$pkgdir"/usr/share/texmf-dist/'{}' \;
37 find $dir -type f -exec install -m644 '{}' "$pkgdir"/usr/share/texmf-dist/'{}' \;
39 if [[ -d texmf-dist ]]; then
40 find texmf-dist -type d -exec install -d -m755 "$pkgdir"/usr/share/'{}' \;
41 find texmf-dist -type f -exec install -m644 '{}' "$pkgdir"/usr/share/'{}' \;
43 if [[ -d "$pkgdir"/usr/share/texmf-dist/scripts ]]; then
44 find "$pkgdir"/usr/share/texmf-dist/scripts -type f -exec chmod a+x '{}' \;
47 install -m755 -d "$pkgdir"/usr/bin
48 ln -s /usr/share/texmf-dist/scripts/lilyglyphs/lily-glyph-commands.py "$pkgdir"/usr/bin/lily-glyph-commands
49 ln -s /usr/share/texmf-dist/scripts/lilyglyphs/lily-image-commands.py "$pkgdir"/usr/bin/lily-image-commands
50 ln -s /usr/share/texmf-dist/scripts/lilyglyphs/lily-rebuild-pdfs.py "$pkgdir"/usr/bin/lily-rebuild-pdfs
51 ln -s /usr/share/texmf-dist/scripts/m-tx/m-tx.lua "$pkgdir"/usr/bin/m-tx
52 ln -s /usr/share/texmf-dist/scripts/musixtex/musixflx.lua "$pkgdir"/usr/bin/musixflx
53 ln -s /usr/share/texmf-dist/scripts/musixtex/musixtex.lua "$pkgdir"/usr/bin/musixtex
54 ln -s /usr/share/texmf-dist/scripts/pmxchords/pmxchords.lua "$pkgdir"/usr/bin/pmxchords