1 # Maintainer: Firmicus <firmicus āt gmx dōt net>
2 # Maintainer: Rémy Oudompheng <remy@archlinux.org>
4 pkgname=texlive-publishers
8 pkgdesc="TeX Live - LaTeX classes and packages for specific publishers"
11 depends=('texlive-core')
12 groups=('texlive-most')
13 url='http://tug.org/texlive/'
14 source=("https://sources.archlinux.org/other/texlive/$pkgname-$pkgver-src.zip")
15 options=('!emptydirs')
16 sha256sums=('52f9d38288dcaabfd67f0cb07fb8a48f2c709ff80e5085b298a2cedc9af88588')
23 rm -rf {tlpkg,doc,source} || true
27 install -m755 -d "$pkgdir"/var/lib/texmf/arch/installedpkgs
28 sed -i '/^#/d' CONTENTS
29 install -m644 CONTENTS "$pkgdir"/var/lib/texmf/arch/installedpkgs/${pkgname}_${_revnr}.pkgs
30 install -m755 -d "$pkgdir"/usr/share
31 wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && echo $d; done) || true
32 for dir in $wanteddirs; do
33 find $dir -type d -exec install -d -m755 "$pkgdir"/usr/share/texmf-dist/'{}' \;
34 find $dir -type f -exec install -m644 '{}' "$pkgdir"/usr/share/texmf-dist/'{}' \;
36 if [[ -d texmf-dist ]]; then
37 find texmf-dist -type d -exec install -d -m755 "$pkgdir"/usr/share/'{}' \;
38 find texmf-dist -type f -exec install -m644 '{}' "$pkgdir"/usr/share/'{}' \;
40 if [[ -d "$pkgdir"/usr/share/texmf-dist/scripts ]]; then
41 find "$pkgdir"/usr/share/texmf-dist/scripts -type f -exec chmod a+x '{}' \;