1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Olli <olli@suruatoel.xyz>
7 pkgdesc='Open source implementation of the Java Servlet 5.0 and JavaServer Pages 3.0 technologies'
9 url=https://tomcat.apache.org/
22 optdepends=('tomcat-native: to allow optimal performance in production environments')
24 etc/tomcat10/catalina.policy
25 etc/tomcat10/catalina.properties
26 etc/tomcat10/context.xml
27 etc/tomcat10/logging.properties
28 etc/tomcat10/server.xml
29 etc/tomcat10/tomcat-users.xml
32 install=tomcat10.install
33 _tag=5d45c1a9359c2298d7140c1ca90cb8c43809a168
35 git+https://github.com/apache/tomcat.git#tag=${_tag}
41 '2bdf5f9e0ff8766363b2f0ac636415ee416bcfc3f4cc2859e1917d5352da827d0d25dc1c81260c38c1cf3e149d3701931b5a6bd0f32daeed9af4612dbc0b1f72'
42 'ab6584d66e0e2e4d094a54d658af6e6397cbfee56ed211a6add84763d3b89c9e260127387a318c531f23182abde59c2289986773658f45e1c877687e1233b477'
43 '79ef7469fd113253479e212ed5faf9ec7e0e55b4eba25a120d1e3814b35241b6f8f2e78b1b36554088c8944b2652b8e304fd16615132db057e76a32a7778a39d')
51 _pkgver=$(git describe --tags)
52 if [[ ${_pkgver} != 10.* ]]; then
60 cp build.properties.default build.properties
61 sed "/^base\.path=/c\base\.path=${srcdir}" -i build.properties
62 sed "/^compile.debug=/c\compile.debug=false" -i build.properties
63 sed "/^trydownload.httpusecaches=/c\trydownload.httpusecaches=false" -i build.properties
68 export JAVA_HOME=/usr/lib/jvm/java-11-openjdk
69 export PATH="$JAVA_HOME/bin:$PATH"
74 cd tomcat/output/build
76 # Tomcat general files
77 install -dm 755 "${pkgdir}"/usr/share/tomcat10/bin
78 install -m 755 bin/* -t "${pkgdir}"/usr/share/tomcat10/bin/
79 # commons-daemon is packaged on its own
80 rm "${pkgdir}"/usr/share/tomcat10/bin/{*.bat,commons-daemon*}
81 ln -s /usr/share/java/commons-daemon.jar "${pkgdir}"/usr/share/tomcat10/bin/commons-daemon.jar
83 install -dm 755 "${pkgdir}"/usr/share/java/tomcat10
84 install -m 644 lib/* -t "${pkgdir}"/usr/share/java/tomcat10/
85 # eclipse-ecj is packaged on its own
86 rm "${pkgdir}"/usr/share/java/tomcat10/ecj-*.jar
87 ln -s ../eclipse-ecj.jar "${pkgdir}"/usr/share/java/tomcat10/ecj.jar
89 ln -s /usr/share/java/tomcat10 "${pkgdir}"/usr/share/tomcat10/lib
91 # We log through systemd but this would still be required for stock Tomcat logging
92 install -dm 775 -o ${_uid_tomcat} -g ${_gid_log} "${pkgdir}"/var/log/tomcat10
93 ln -s /var/log/tomcat10 "${pkgdir}"/usr/share/tomcat10/logs
94 touch "${pkgdir}"/var/log/tomcat10/catalina.{out,err}
95 chgrp ${_gid_log} "${pkgdir}"/var/log/tomcat10/catalina.{out,err}
97 install -dm 775 "${pkgdir}"/etc/tomcat10
98 install -m 640 -g ${_gid_tomcat} conf/* -t "${pkgdir}"/etc/tomcat10/
100 install -dm 775 -g ${_gid_tomcat} "${pkgdir}"/etc/tomcat10/Catalina
101 ln -s /etc/tomcat10 "${pkgdir}"/usr/share/tomcat10/conf
103 install -dm 775 "${pkgdir}"/var/lib/tomcat10
104 cp -dr --no-preserve=ownership webapps "${pkgdir}"/var/lib/tomcat10/
105 chown -R ${_uid_tomcat}:${_gid_tomcat} "${pkgdir}"/var/lib/tomcat10
106 chmod 775 "${pkgdir}"/var/lib/tomcat10/webapps
107 ln -s /var/lib/tomcat10/webapps "${pkgdir}"/usr/share/tomcat10/webapps
109 install -dm 1777 "${pkgdir}"/var/tmp
110 install -dm 775 -o ${_uid_tomcat} -g ${_gid_tomcat} "${pkgdir}"/var/tmp/tomcat10/{temp,work}
111 ln -s /var/tmp/tomcat10/temp "${pkgdir}"/usr/share/tomcat10/temp
112 ln -s /var/tmp/tomcat10/work "${pkgdir}"/usr/share/tomcat10/work
114 install -Dm 644 ../../../tomcat10.service -t "${pkgdir}"/usr/lib/systemd/system/
115 install -Dm 644 ../../../tomcat10.sysusers "${pkgdir}"/usr/lib/sysusers.d/tomcat10.conf
116 install -Dm 644 ../../../tomcat10.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/tomcat10.conf