archrelease: copy trunk to extra-x86_64
[arch-packages.git] / unixodbc / trunk / PKGBUILD
blobe22c624f02c15e5247eacc305420e5bdb555b727
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Judd Vinet <jvinet@zeroflux.org>
3 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
5 pkgname=unixodbc
6 pkgver=2.3.11
7 pkgrel=1
8 pkgdesc="ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources"
9 arch=('x86_64')
10 license=('GPL2' 'LGPL2.1')
11 url="http://www.unixodbc.org/"
12 backup=('etc/odbc.ini' 'etc/odbcinst.ini')
13 depends=('readline' 'libltdl')
14 source=(ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-$pkgver.tar.gz)
15 sha256sums=('d9e55c8e7118347e3c66c87338856dad1516b490fb7c756c1562a2c267c73b5c')
17 build() {
18     cd unixODBC-${pkgver}
19     ./configure --prefix=/usr --sysconfdir=/etc
20     sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21     make
24 check() {
25     cd unixODBC-${pkgver}
26     make -k check
29 package() {
30     cd unixODBC-${pkgver}
31     make DESTDIR="${pkgdir}" install
32     touch "$pkgdir"/etc/{odbc,odbcinst}.ini