1 # Maintainer: Jan de Groot <jgc@archlinux.org>
6 pkgdesc="Virtual Terminal Emulator widget for use with GTK2"
10 depends=('gtk2' 'vte-common')
11 makedepends=('pygtk' 'intltool' 'gobject-introspection' 'pygobject2-devel')
12 url="https://www.gnome.org"
13 source=(https://download.gnome.org/sources/vte/0.28/vte-$pkgver.tar.xz
16 bracketed_paste_mode_fix.patch)
17 sha256sums=('86cf0b81aa023fa93ed415653d51c96767f20b2d7334c893caba71e42654b0ae'
18 '2cd58ffffd42a9d59e05369c2efa1e70b7d32bfb5c8cdbd67b3b95ae3c3e6d61'
19 '9a99c486b1c0377a4b8c6fae25067c68913bded2988fafea2c86f5adf6a49c81'
20 '634d4526efdff9fac0e75cb056afb0a886354cd52c5dc98f5a70bef282631724')
24 patch -Np1 -i ../make_alt_work.patch
25 patch -Np1 -i ../scroll_region.patch
26 patch -Np1 -i ../bracketed_paste_mode_fix.patch
27 rm -r doc/reference/html
31 #warning: type-punning to incomplete type might break strict-aliasing rules
32 export CFLAGS="$CFLAGS -fno-strict-aliasing"
34 PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
35 --libexecdir=/usr/lib/vte \
36 --localstatedir=/var --disable-static \
37 --enable-introspection --with-gtk=2.0 --disable-gnome-pty-helper
38 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
44 make DESTDIR="$pkgdir" install