archrelease: copy trunk to extra-x86_64
[arch-packages.git] / wayland-utils / trunk / PKGBUILD
blob3179297a531ba845d9aa2175879967d4ea46ca91
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Lex Black <autumn-wind@web.de>
4 pkgname=wayland-utils
5 pkgver=1.1.0
6 pkgrel=1
7 pkgdesc='Wayland tools to display information about current compositor'
8 url='https://gitlab.freedesktop.org/wayland/wayland-utils'
9 arch=(x86_64)
10 license=(MIT)
11 depends=(wayland libdrm)
12 makedepends=(meson wayland-protocols)
13 source=(https://gitlab.freedesktop.org/wayland/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('736fae5eb93e7eb6cdaa2374583b82912d2a497853ee8a1b3aeec0109ddd82dc')
16 build() {
17   meson $pkgname-$pkgver build \
18     --prefix /usr
19   meson compile -C build
22 package() {
23   meson install -C build --destdir "$pkgdir"
25   install -Dm644 $pkgname-$pkgver/COPYING -t "$pkgdir"/usr/share/licenses/$pkgname