1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
10 pkgdesc="Embeddable web content engine"
11 url="https://wpewebkit.org"
66 $url/releases/wpewebkit-$pkgver.tar.xz{,.asc}
68 sha256sums=('c6b25e168b70f2121305ed078d0790e0aa4b0c73fce44e32ed42d4e5dd137ccb'
71 'D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3' # Carlos Garcia Campos <cgarcia@igalia.com>
72 '5AA3BC334FD7E3369E7C77B291C559DBE4C9123B' # Adrián Pérez de Castro <aperez@igalia.com>
82 -DCMAKE_BUILD_TYPE=Release
83 -DCMAKE_INSTALL_PREFIX=/usr
84 -DCMAKE_INSTALL_LIBDIR=lib
85 -DCMAKE_INSTALL_LIBEXECDIR=lib
88 -DENABLE_WPE_1_1_API=ON
89 -DENABLE_DOCUMENTATION=ON
90 -DENABLE_MINIBROWSER=ON
93 # Produce minimal debug info: 4.3 GB of debug data makes the
94 # build too slow and is too much to package for debuginfod
98 cmake -S wpewebkit-$pkgver -B build -G Ninja "${cmake_options[@]}"
102 package_wpewebkit() {
104 libWPEBackend-fdo-1.0.so
111 'geoclue: Geolocation support'
112 'gst-libav: nonfree media decoding'
113 'gst-plugins-bad: media decoding'
114 'gst-plugins-good: media decoding'
117 DESTDIR="$pkgdir" cmake --install build
119 mkdir -p doc/usr/share
120 mv {"$pkgdir",doc}/usr/share/gtk-doc
123 find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | sort -z |
124 while IFS= read -d $'\0' -r _f; do
129 install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
132 package_wpewebkit-docs() {
133 pkgdesc+=" (documentation)"
139 # vim:set sw=2 sts=-1 et: