archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xcb-util-image / trunk / PKGBUILD
blob80081fca21d89eccd7e90c153622a3a71edbd6f4
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xcb-util-image
5 pkgver=0.4.1
6 pkgrel=2
7 pkgdesc="Utility libraries for XC Binding - Port of Xlib's XImage and XShmImage functions"
8 arch=('x86_64')
9 url="https://xcb.freedesktop.org"
10 license=('custom')
11 depends=('libxcb' 'xcb-util')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 source=(https://xorg.freedesktop.org/archive/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
14 sha512sums=('9b47ba38b91196d76541b6ccabeaf291d3b91036f15422909cd6a79b3fd1a9786d5b1728e411bc41cfdf3d60a253485f4ef7c65ffa6ae646fa93439ec782746e'
15             'SKIP')
16 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
18 build() {
19   cd ${pkgname}-${pkgver}
20   ./configure --prefix=/usr --disable-static
21   make
24 check() {
25   cd ${pkgname}-${pkgver}
26   make check
29 package() { 
30   cd ${pkgname}-${pkgver}
31   make DESTDIR="${pkgdir}" install
33   install -D -m644 COPYING \
34     "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING