archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xcb-util-wm / repos / extra-x86_64 / PKGBUILD
blobe323673524982e4896f7895193dace9f03eab61f
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Controbutor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xcb-util-wm
5 pkgver=0.4.2
6 pkgrel=1
7 pkgdesc="Utility libraries for XC Binding - client and window-manager helpers for ICCCM"
8 arch=('x86_64')
9 url="https://xcb.freedesktop.org"
10 license=('custom')
11 depends=('libxcb')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 options=('debug')
14 source=(https://xorg.freedesktop.org/archive/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
15 sha512sums=('eab6588e6a47d28a3b25ecd13b5018529419db6b49c74458c093699b60a194933be1e1f6f7799abf03344f7ebc7af88586ff2935938d53644bdd5c763a7fa9b0'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
19 build() {
20   cd ${pkgname}-${pkgver}
21   ./configure --prefix=/usr --disable-static
22   make
25 check() {
26   cd ${pkgname}-${pkgver}
27   make check
30 package() { 
31   cd ${pkgname}-${pkgver}
32   make DESTDIR="${pkgdir}" install
33   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"