archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xdg-desktop-portal-gnome / repos / extra-x86_64 / PKGBUILD
blob66fbe1c4c5c8bf25723d71f92828c90ff6dc8d0e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=xdg-desktop-portal-gnome
4 pkgver=44.1
5 pkgrel=2
6 pkgdesc="A backend implementation for xdg-desktop-portal for the GNOME desktop environment"
7 url="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(
11   gnome-desktop-4
12   gnome-keyring
13   libadwaita
14   'xdg-desktop-portal-gtk>=1.10.0-2'
16 makedepends=(
17   git
18   meson
19   xdg-desktop-portal
21 optdepends=('evince: Print previews')
22 provides=(xdg-desktop-portal-impl)
23 conflicts=('xdg-desktop-portal-gtk<1.10.0-2')
24 replaces=('xdg-desktop-portal-gtk<1.10.0-2')
25 groups=(gnome)
26 _commit=89203bf3522556965fc225782d1a635afdac611e  # tags/44.1^0
27 source=("git+https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome.git#commit=$_commit")
28 b2sums=('SKIP')
30 pkgver() {
31   cd $pkgname
32   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
35 prepare() {
36   cd $pkgname
39 build() {
40   arch-meson $pkgname build
41   meson compile -C build
44 check() {
45   meson test -C build --print-errorlogs
48 package() {
49   meson install -C build --destdir "$pkgdir"
52 # vim:set sw=2 sts=-1 et: