archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfce4-settings / repos / extra-x86_64 / PKGBUILD
blob467af9f82c67cc0034f39ffa1127471f5c0a15ad
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: tobias <tobias funnychar archlinux.org>
3 # Contributor: Corrado Primier <bardo@aur.archlinux.org>
5 pkgname=xfce4-settings
6 pkgver=4.18.2
7 pkgrel=1
8 pkgdesc="Xfce's Configuration System"
9 arch=('x86_64')
10 url="https://docs.xfce.org/xfce/xfce4-settings/start"
11 license=('GPL2')
12 groups=('xfce4')
13 depends=('exo' 'garcon' 'libxfce4ui' 'xfconf' 'libnotify' 'libcanberra'
14          'colord' 'libxklavier' 'elementary-icon-theme' 'gnome-themes-extra')
15 makedepends=('intltool' 'xf86-input-libinput')
16 optdepends=('python: xfce4-compose-mail -- "mailto:" URI handling')
17 source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
18         default-xsettings-xml.patch)
19 sha256sums=('4661361087faae57efb49741ffcf90bf9078760e163bbdef63b924083bdc4f22'
20             'ca1c7562e209d9ab791b02f2a886c61a9ed705a912d9575f590734eff21d6e5c')
21 prepare() {
22   cd $pkgname-$pkgver
24   # Enable Adwaita theme, elementary icon theme and font hinting by default
25   patch -Np1 -i "$srcdir/default-xsettings-xml.patch"
28 build() {
29   cd $pkgname-$pkgver
31   ./configure \
32     --prefix=/usr \
33     --sysconfdir=/etc \
34     --localstatedir=/var \
35     --enable-xrandr \
36     --enable-xcursor \
37     --enable-libnotify \
38     --enable-libxklavier \
39     --enable-pluggable-dialogs \
40     --enable-sound-settings \
41     --disable-debug
42   make
45 package() {
46   cd $pkgname-$pkgver
47   make DESTDIR="$pkgdir" install
50 # vim:set ts=2 sw=2 et: