archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfwm4 / repos / extra-x86_64 / PKGBUILD
blob80c6e3a38c761c5a924105378a93605581478ce9
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: tobias <tobias funnychar archlinux.org>
4 pkgname=xfwm4
5 pkgver=4.18.0
6 pkgrel=1
7 pkgdesc="Xfce's window manager"
8 arch=('x86_64')
9 url="https://docs.xfce.org/xfce/xfwm4/start"
10 license=('GPL2')
11 groups=('xfce4')
12 depends=('libxfce4ui' 'xfconf' 'libwnck3' 'libepoxy' 'libxpresent'
13          'hicolor-icon-theme')
14 makedepends=('intltool')
15 source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
16 sha256sums=('92cd1b889bb25cb4bc06c1c6736c238d96e79c1e706b9f77fad0a89d6e5fc13f')
18 build() {
19   cd $pkgname-$pkgver
21   ./configure \
22     --prefix=/usr \
23     --sysconfdir=/etc \
24     --localstatedir=/var \
25     --enable-startup-notification \
26     --enable-randr \
27     --enable-compositor \
28     --enable-xsync \
29     --disable-debug
30   make
33 package() {
34   cd $pkgname-$pkgver
35   make DESTDIR="$pkgdir" install
38 # vim:set ts=2 sw=2 et: