archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xmlsec / repos / extra-x86_64 / PKGBUILD
blobbda8e472f0d9d7dbb2162c650e52ca76c247dd31
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
5 pkgname=xmlsec
6 pkgver=1.2.37
7 pkgrel=1
8 pkgdesc="XML Security Library is a C library based on LibXML2"
9 license=('custom')
10 arch=('x86_64')
11 url="https://www.aleksey.com/xmlsec/index.html"
12 depends=('libxslt' 'openssl' 'gnutls' 'nss' 'libltdl')
13 provides=('libxmlsec1.so' 'libxmlsec1-openssl.so' 'libxmlsec1-nss.so' 'libxmlsec1-gnutls.so' 'libxmlsec1-gcrypt.so')
14 options=('debug')
15 #source=(https://www.aleksey.com/xmlsec/download/${pkgname}1-${pkgver}.{tar.gz,sig}) # signature file not compatible
16 source=(https://www.aleksey.com/xmlsec/download/${pkgname}1-${pkgver}.tar.gz)
17 sha256sums=('5f8dfbcb6d1e56bddd0b5ec2e00a3d0ca5342a9f57c24dffde5c796b2be2871c')
18 #validpgpkeys=('') #
20 build() {
21   cd ${pkgname}1-${pkgver}
22   ./configure --prefix=/usr --disable-static
23   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
24   make
27 check() {
28   cd ${pkgname}1-$pkgver
29   make check
32 package() {
33   cd ${pkgname}1-${pkgver}
34   make DESTDIR="${pkgdir}" install
35   install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"