archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xorg-iceauth / repos / extra-x86_64 / PKGBUILD
blob7c09ca85128bc9d77f8707ea0d31c288b66d515a
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=xorg-iceauth
5 pkgver=1.0.9
6 pkgrel=1
7 pkgdesc="ICE authority file utility"
8 arch=(x86_64)
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libice')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 groups=('xorg-apps' 'xorg')
14 source=(https://xorg.freedesktop.org/archive/individual/app/iceauth-${pkgver}.tar.xz{,.sig})
15 sha512sums=('16b2f58008587cf1544037ca8b1c76dbb75eb043b3048b3064e66ba6b147962233f1453c2cf18bfb136dd6dd21d3e27b5219e17e1ab7b81dbe93fb6aff801a72'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
19 build() {
20   cd "${srcdir}/iceauth-${pkgver}"
21   ./configure --prefix=/usr
22   make
25 package() {
26   cd "${srcdir}/iceauth-${pkgver}"
27   make DESTDIR="${pkgdir}" install
28   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
29   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"