archrelease: copy trunk to extra-x86_64
[arch-packages.git] / zvbi / repos / extra-x86_64 / PKGBUILD
blob3c0352cf890127c28ed721f834a7269ef101908f
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Alexander Baldeck <alexander@archlinux.org>
3 # Contributor: dorphell <dorphell@archlinux.org>
5 pkgname=zvbi
6 pkgver=0.2.41
7 pkgrel=1
8 pkgdesc='VBI capture and decoding library'
9 url=http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome
10 arch=(x86_64)
11 depends=(
12   libpng
13   libx11
15 makedepends=(git)
16 license=(
17   BSD
18   GPL2
19   LGPL2.1
20   MIT
22 _tag=74016b7aef2f52f44920a04f9bcfe52ed72905d1
23 #source=(git+https://github.com/zapping-vbi/zvbi.git?signed#tag=${_tag})
24 source=(git+https://github.com/zapping-vbi/zvbi.git#tag=${_tag})
25 b2sums=(SKIP)
26 validpgpkeys=(FA26CA784BE188927F22B99F6570EA01146F7354) # Ileana Dumitrescu <ileanadumitrescu95@gmail.com>
28 prepare() {
29   cd zvbi
30   NOCONFIGURE=1 ./autogen.sh
33 pkgver() {
34   cd zvbi
35   git describe --tags | sed 's/^v//'
38 build() {
39   cd zvbi
40   ./configure \
41     --prefix=/usr \
42     --sbindir=/usr/bin
43   make
46 package() {
47   cd zvbi
48   make DESTDIR="${pkgdir}" install
49   install -Dm 644 COPYING.md -t "${pkgdir}"/usr/share/licenses/zvbi
52 # vim: ts=2 sw=2 et: