1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=accounts-qml-module
6 pkgdesc='Expose the Online Accounts API to QML applications'
7 url='https://gitlab.com/accounts-sso/accounts-qml-module'
10 depends=(signond libaccounts-qt qt5-declarative)
11 makedepends=(qt5-tools)
12 source=(https://gitlab.com/accounts-sso/$pkgname/-/archive/VERSION_$pkgver/$pkgname-VERSION_$pkgver.tar.gz
13 accounts-qml-module-qmltypes.patch::https://gitlab.com/accounts-sso/accounts-qml-module/-/commit/678c493a.patch)
14 sha256sums=('550a6c684bf4b4f6460a35bac0cf3afbb9090a5cf4038b880c6b86c2e9ea0195'
15 'ae1142ba51f261a9e5c128fcb6c7518c642fc17ce0d908e31e8af14440db9faa')
19 sed -e 's/-Werror//' -i $pkgname-VERSION_$pkgver/common-project-config.pri
20 patch -d $pkgname-VERSION_$pkgver -p1 -i ../accounts-qml-module-qmltypes.patch
25 qmake-qt5 ../$pkgname-VERSION_$pkgver/$pkgname.pro PREFIX=/usr
31 make INSTALL_ROOT="$pkgdir" install_subtargets # skip docs
32 rm -r "$pkgdir"/usr/bin # Remove test binary