OCaml 4.13.1 rebuild
[arch-packages.git] / fuse2 / repos / extra-x86_64 / PKGBUILD
blobb0b74badb292b86570a5c3125e50591b32541f31
1 # Maintainer: Ronald van Haren <ronald.archlinux.org>
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: Mark Rosenstand <mark@archlinux.org>
5 pkgname=fuse2
6 pkgver=2.9.9
7 pkgrel=4
8 pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
9 arch=('x86_64')
10 url='https://github.com/libfuse/libfuse'
11 license=('GPL2')
12 provides=(fuse=$pkgver) # TODO: remove it once all packages start to use 'fuse2' name
13 replaces=('fuse')
14 conflicts=('fuse')
15 depends=('glibc' 'fuse-common')
16 makedepends=('pkg-config')
17 options=(!emptydirs)
18 source=(https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.gz{,.asc})
19 sha1sums=('943ba651b14bc4a3c6fd959ed4b8c04f4a59032d'
20           'SKIP')
21 validpgpkeys=(ED31791B2C5C1613AF388B8AD113FCAC3C4E599F) # Nikolaus Rath <Nikolaus@rath.org>
23 build() {
24   cd fuse-$pkgver
26   UDEV_RULES_PATH=/usr/lib/udev/rules.d MOUNT_FUSE_PATH=/usr/bin ./configure --prefix=/usr --libdir=/usr/lib --enable-lib --enable-util --disable-example
27   make
30 package() {
31   cd fuse-$pkgver
33   make DESTDIR=${pkgdir} install
35   # Remove init script in wrong path
36   # Don't add our own for now, as fusectl fs oopses on 2.6.18
37   rm -r ${pkgdir}/etc/init.d
39   # static device nodes are handled by udev
40   rm -r ${pkgdir}/dev