1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Automatic archives creating and extracting library"
8 url="https://wiki.gnome.org/TingweiLan/GSoC2013Final"
11 depends=(glib2 libarchive gtk3)
12 makedepends=(git gobject-introspection gtk-doc vala meson)
13 provides=(libgnome-autoar{,-gtk}-${pkgver%%.*}.so)
14 _commit=5f1511bde55255fdae94c1cb8b8b2223f10dfd0b # tags/0.4.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-autoar.git#commit=$_commit")
20 git describe --tags | sed 's/-/+/g'
28 arch-meson $pkgname build \
32 meson compile -C build
36 meson test -C build --print-errorlogs
40 meson install -C build --destdir "$pkgdir"