OCaml 4.13.1 rebuild
[arch-packages.git] / gnome-autoar / repos / extra-x86_64 / PKGBUILD
blob04aadcdcd15a17678b78ac783baf6f567e477c9a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-autoar
5 pkgver=0.4.1
6 pkgrel=1
7 pkgdesc="Automatic archives creating and extracting library"
8 url="https://wiki.gnome.org/TingweiLan/GSoC2013Final"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(glib2 libarchive gtk3)
12 makedepends=(git gobject-introspection gtk-doc vala meson)
13 provides=(libgnome-autoar{,-gtk}-${pkgver%%.*}.so)
14 _commit=5f1511bde55255fdae94c1cb8b8b2223f10dfd0b  # tags/0.4.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-autoar.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build \
29     -D gtk_doc=true \
30     -D tests=true \
31     -D vapi=true
32   meson compile -C build
35 check() {
36   meson test -C build --print-errorlogs
39 package() {
40   meson install -C build --destdir "$pkgdir"