OCaml 4.13.1 rebuild
[arch-packages.git] / gtk2 / trunk / PKGBUILD
blob4c063e9f64cd0512675109f864589ebb4b634e86
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=gtk2
5 pkgver=2.24.33
6 pkgrel=2
7 pkgdesc="GObject-based multi-platform GUI toolkit (legacy)"
8 arch=(x86_64)
9 url="https://www.gtk.org/"
10 depends=(atk pango libxcursor libxinerama libxrandr libxi libxcomposite libxdamage
11          shared-mime-info cairo libcups gtk-update-icon-cache librsvg desktop-file-utils)
12 makedepends=(gobject-introspection git gtk-doc)
13 optdepends=('gnome-themes-standard: Default widget theme'
14             'adwaita-icon-theme: Default icon theme'
15             'python: gtk-builder-convert')
16 provides=(libgailutil.so libg{d,t}k-x11-2.0.so)
17 license=(LGPL)
18 install=gtk2.install
19 _commit=68631945733158f164427db84f01301d7e875763  # tags/2.24.33^0
20 source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
21         gtkrc
22         gtk-query-immodules-2.0.hook
23         xid-collision-debug.patch)
24 sha256sums=('SKIP'
25             'bc968e3e4f57e818430130338e5f85a5025e21d7e31a3293b8f5a0e58362b805'
26             '427e7ed2626465ea7a8986189b6c8340a0520b9f7b8e2a56cd1169d375da7425'
27             '7724a55c4916318ed81b22f21c37c0a66e78adce017563fed6d84d813a4b80bc')
29 pkgver() {
30   cd gtk
31   git describe --tags | sed 's/-/+/g'
34 prepare() {
35   cd gtk
36   git apply -3 ../xid-collision-debug.patch
37   NOCONFIGURE=1 ./autogen.sh
40 build() {
41   cd gtk
43   ./configure \
44     --prefix=/usr \
45     --sysconfdir=/etc \
46     --localstatedir=/var \
47     --with-xinput=yes \
48     --disable-gtk-doc
50   # https://bugzilla.gnome.org/show_bug.cgi?id=655517
51   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
53   make
56 package() {
57   cd gtk
58   make DESTDIR="$pkgdir" install
60   install -Dt "$pkgdir/usr/share/gtk-2.0" -m644 ../gtkrc
61   install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../gtk-query-immodules-2.0.hook
63   rm "$pkgdir/usr/bin/gtk-update-icon-cache"
66 # vim:set et sw=2: