OCaml 4.13.1 rebuild
[arch-packages.git] / hitori / trunk / PKGBUILD
blob203d5726e227b4f7305b884cc155a91f78d2ee31
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
4 pkgname=hitori
5 pkgver=3.38.3
6 pkgrel=1
7 pkgdesc="GTK+ application to generate and let you play games of Hitori"
8 arch=(x86_64)
9 url="https://wiki.gnome.org/Apps/Hitori"
10 license=(GPL)
11 depends=(gtk3)
12 makedepends=(yelp-tools appstream-glib git meson)
13 groups=(gnome-extra)
14 _commit=60d2f0231c2702128c7d569a1c95c2f533080286  # tags/3.38.3^0
15 source=("git+https://gitlab.gnome.org/GNOME/hitori.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"