OCaml 4.13.1 rebuild
[arch-packages.git] / python-chardet / repos / testing-any / PKGBUILD
blob298a80f6732caaeeb3c14877572429b8b6551db8
1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: William Rea <sillywilly@gmail.com>
5 pkgname=python-chardet
6 pkgver=4.0.0
7 pkgrel=5
8 arch=('any')
9 url="https://github.com/chardet/chardet"
10 license=('LGPL')
11 depends=('python')
12 pkgdesc="Python3 module for character encoding auto-detection"
13 makedepends=('python-setuptools')
14 checkdepends=('python-pytest')
15 source=("https://pypi.io/packages/source/c/chardet/chardet-${pkgver}.tar.gz")
16 sha512sums=('ebd7f420e1094445270db993f6373ffe7370419e002b0bb13299dc6c9b0f7c4e77b0f44f871fba6371e6869e7c86728514367db377e3137487a3acf50cb81e96')
18 build() {
19    cd "$srcdir"/chardet-$pkgver
20    python setup.py build
23 check() {
24    cd "$srcdir"/chardet-$pkgver
25    python -m pytest
28 package() {
29    cd chardet-$pkgver
30    python setup.py install --root="$pkgdir" --optimize=1