1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-shell-extensions
6 pkgdesc="Extensions for GNOME shell, including classic mode"
7 url="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
11 makedepends=(meson git sassc)
12 optdepends=('gnome-menus: applications menu extension')
14 _commit=de48d02c625a8a4177ff82899d68420e1585b028 # tags/43.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-shell-extensions.git#commit=$_commit"
16 "git+https://gitlab.gnome.org/GNOME/gnome-shell-sass.git")
22 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 git submodule set-url data/gnome-shell-sass "$srcdir/gnome-shell-sass"
30 git -c protocol.file.allow=always submodule update
39 arch-meson $pkgname build "${meson_options[@]}"
40 meson compile -C build
44 meson test -C build --print-errorlogs
48 meson install -C build --destdir "$pkgdir"
51 # vim:set sw=2 sts=-1 et: