upgpkg: sbcl 2.3.1-1
[arch-packages.git] / gnome-system-monitor / trunk / PKGBUILD
blobdd13d683562c580e5768d0cbd449db8a85857503
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-system-monitor
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="View current processes and monitor system state"
8 url="https://wiki.gnome.org/Apps/SystemMonitor"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(libgtop gtkmm3 librsvg systemd libhandy polkit)
12 makedepends=(meson yelp-tools git appstream-glib)
13 groups=(gnome)
14 _commit=c12390a98881add02d6457e4f84a32ca811685ec  # tags/42.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-system-monitor.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"