upgpkg: sbcl 2.3.1-1
[arch-packages.git] / l-smash / repos / extra-x86_64 / PKGBUILD
blob935861da05feab5aa6bb25c9ba1f921943baa52b
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
4 pkgname=l-smash
5 pkgver=2.14.5
6 pkgrel=2
7 pkgdesc='MP4 muxer and other tools'
8 arch=('x86_64')
9 url='https://github.com/l-smash/l-smash'
10 license=('custom')
11 depends=('glibc')
12 provides=('liblsmash.so')
13 source=("l-smash-${pkgver}.tar.gz::https://github.com/l-smash/l-smash/archive/v${pkgver}.tar.gz")
14 sha256sums=('e6f7c31de684f4b89ee27e5cd6262bf96f2a5b117ba938d2d606cf6220f05935')
16 build() {
17   cd l-smash-${pkgver}
19   ./configure \
20     --prefix='/usr' \
21     --enable-shared \
22     --disable-static \
23     --extra-cflags="$CFLAGS" \
24     --extra-ldflags="$LDFLAGS"
25   make
28 package() {
29   cd l-smash-${pkgver}
31   make DESTDIR="${pkgdir}" install
33   install -dm 755 "${pkgdir}"/usr/share/licenses/l-smash
34   install -m 644 LICENSE "${pkgdir}"/usr/share/licenses/l-smash/
37 # vim: ts=2 sw=2 et: