upgpkg: sbcl 2.3.1-1
[arch-packages.git] / link-grammar / repos / extra-x86_64 / PKGBUILD
blob9eea8116c12b9e6fac539eb202f6460c8c6f11e5
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=link-grammar
5 pkgver=5.12.0
6 pkgrel=1
7 pkgdesc="A Grammar Checking library"
8 arch=('x86_64')
9 url="https://www.abisource.com/projects/link-grammar/"
10 license=('LGPL')
11 depends=('hunspell' 'sqlite' 'libedit')
12 makedepends=('python' 'swig' 'apache-ant' 'java-environment=11')
13 options=('!makeflags')
14 source=(https://www.abisource.com/downloads/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz{,.asc})
15 validpgpkeys=('6407453C98BECC19ADB03D82EB6AA534E0C0651C'
16               '8305252160000B5E89843F5464A99A8201045933') # Linas Vepstas <linasvepstas@gmail.com>
17 sha256sums=('3f113daca2bd3ec8c20c7f86d5ef7e56cf8f80135f903bb7569924d6d0720383'
18             'SKIP')
20 build() {
21   cd ${pkgname}-${pkgver}
23   ./configure --prefix=/usr
25   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
26   make
29 package() {
30   cd ${pkgname}-${pkgver}
32   make DESTDIR="${pkgdir}" install