upgpkg: sbcl 2.3.1-1
[arch-packages.git] / simple-scan / trunk / PKGBUILD
blob98db7790452bbfa4c06d27c8b0a914921aac0ab1
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Thomas Dziedzic < gostrc at gmail >
3 # Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
4 # Contributor: Joeny Ang <ang(dot)joeny(at)gmail(dot)com>
6 pkgname=simple-scan
7 pkgver=42.5
8 pkgrel=1
9 pkgdesc="Simple scanning utility"
10 url="https://gitlab.gnome.org/GNOME/simple-scan"
11 arch=(x86_64)
12 license=(GPL3)
13 groups=(gnome)
14 depends=(sane dconf gtk3 colord-sane libgusb libhandy)
15 makedepends=(yelp-tools meson vala git)
16 _commit=a7add634a357caf31e08631d63c29f1d63340934  # tags/42.5^0
17 source=("git+https://gitlab.gnome.org/GNOME/simple-scan.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 sts=-1 et: