upgpkg: sbcl 2.3.1-1
[arch-packages.git] / soundtouch / repos / extra-x86_64 / PKGBUILD
blob6660261c616ae4afa865d9eae854cb5e140769f1
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
4 pkgname=soundtouch
5 pkgver=2.3.2
6 pkgrel=1
7 pkgdesc='An audio processing library'
8 arch=(x86_64)
9 url=https://www.surina.net/soundtouch/
10 license=(LGPL2.1)
11 depends=(gcc-libs)
12 makedepends=(
13   cmake
14   git
15   ninja
17 _tag=29fba832a7920a04eab956b3990c50e13d8c93f9
18 source=(
19   git+https://codeberg.org/soundtouch/soundtouch.git#tag=${_tag}
20   soundtouch-cmake.patch
22 b2sums=('SKIP'
23         '9eed09dc451c4e216a322211622e96757671613a4ba8231a699e32a50764eee4072837df697205dea87ef66a4d4d3105418451bec9cbe4f077ab55718ab374dd')
25 prepare() {
26   cd soundtouch
27   # install autotools files
28   patch -Np1 -i ../soundtouch-cmake.patch
29   # cmake doesn't generate files for autotools
30   autoreconf -fiv
31   ./configure --prefix=/usr --enable-shared
34 pkgver() {
35   cd soundtouch
36   git describe --tags
39 build() {
40   cmake -S soundtouch -B build -G Ninja \
41     -DCMAKE_BUILD_TYPE='' \
42     -DCMAKE_INSTALL_PREFIX=/usr \
43     -DBUILD_SHARED_LIBS=ON
44   cmake --build build
47 package() {
48   DESTDIR="${pkgdir}" cmake --install build
51 # vim: ts=2 sw=2 et: