1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
7 pkgdesc='An audio processing library'
9 url=https://www.surina.net/soundtouch/
17 _tag=29fba832a7920a04eab956b3990c50e13d8c93f9
19 git+https://codeberg.org/soundtouch/soundtouch.git#tag=${_tag}
20 soundtouch-cmake.patch
23 '9eed09dc451c4e216a322211622e96757671613a4ba8231a699e32a50764eee4072837df697205dea87ef66a4d4d3105418451bec9cbe4f077ab55718ab374dd')
27 # install autotools files
28 patch -Np1 -i ../soundtouch-cmake.patch
29 # cmake doesn't generate files for autotools
31 ./configure --prefix=/usr --enable-shared
40 cmake -S soundtouch -B build -G Ninja \
41 -DCMAKE_BUILD_TYPE='' \
42 -DCMAKE_INSTALL_PREFIX=/usr \
43 -DBUILD_SHARED_LIBS=ON
48 DESTDIR="${pkgdir}" cmake --install build