archrelease: copy trunk to extra-x86_64
[arch-packages.git] / aspell / trunk / PKGBUILD
blob1e6b463f624b9e5fd9152edc955a356f945e5ae3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Jochem Kossen <j.kossen@home.nl>
3 # Contributor: dorphell <dorphell@archlinux.org>
4 # Contributor: Thayer Williams <thayer@archlinux.org>
5 # Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
7 pkgname=aspell
8 pkgver=0.60.8
9 _pkgmajorver=0.60
10 pkgrel=2
11 pkgdesc="A spell checker designed to eventually replace Ispell"
12 arch=('x86_64')
13 url="http://aspell.net/"
14 license=('LGPL')
15 depends=('gcc-libs' 'ncurses')
16 optdepends=('perl: to import old dictionaries')
17 source=("https://github.com/GNUAspell/aspell/archive/rel-$pkgver.tar.gz")
18 sha512sums=('b7ca2ed063f003581020d2043b1686915997261695bb0aef6e530431ea55781861ba19e16ce1fb74eb892203c9433c8652d105d380c0a6a24590f13fb1a401be')
20 build() {
21   cd $pkgname-rel-$pkgver
22   PERL_USE_UNSAFE_INC=1 ./autogen
23   ./configure --prefix=/usr --sysconfdir=/etc
24   make
27 package() {
28   cd $pkgname-rel-$pkgver
29   make DESTDIR="$pkgdir" install
30   ln -s $pkgname-$_pkgmajorver "$pkgdir"/usr/lib/$pkgname