archrelease: copy trunk to extra-x86_64
[arch-packages.git] / cln / repos / extra-x86_64 / PKGBUILD
blob7f2a70e373e8ea6b52b0ea9c234952916005b0dc
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=cln
4 pkgver=1.3.6
5 pkgrel=2
6 pkgdesc="Class library for numbers"
7 arch=('x86_64')
8 url="https://www.ginac.de/CLN/"
9 license=('GPL')
10 depends=('gmp')
11 makedepends=('texlive-core')
12 source=(https://www.ginac.de/CLN/${pkgname}-${pkgver}.tar.bz2)
13 sha1sums=('144f15a57f4b25ada0f10ff28458de03578f6f16')
15 build() {
16   cd ${pkgname}-${pkgver}
17   ./configure --prefix=/usr
18   make all html pdf
21 check() {
22   cd ${pkgname}-${pkgver}
23   make check
26 package() {
27   cd ${pkgname}-${pkgver}
28   make DESTDIR="${pkgdir}" install install-html install-pdf