archrelease: copy trunk to extra-x86_64
[arch-packages.git] / evince / trunk / PKGBUILD
blob8877ac70a1fe9e6f207f7485eb8079f67794310c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=evince
5 pkgver=41.3
6 pkgrel=1
7 pkgdesc="Document viewer (PDF, PostScript, XPS, djvu, dvi, tiff, cbr, cbz, cb7, cbt)"
8 url="https://wiki.gnome.org/Apps/Evince"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 libgxps libspectre gsfonts poppler-glib djvulibre t1lib dconf libsecret libsynctex
12          gsettings-desktop-schemas gnome-desktop libarchive gst-plugins-base-libs gspell libhandy
13          gvfs)
14 makedepends=(libnautilus-extension texlive-bin gobject-introspection docbook-xsl python gtk-doc git
15              meson appstream-glib yelp-tools)
16 optdepends=('texlive-bin: DVI support')
17 provides=(libev{document,view}3.so)
18 groups=(gnome)
19 _commit=08780f527ac0306f527c48ea6cc77a7b2c6c5fa8  # tags/41.3^0
20 source=("git+https://gitlab.gnome.org/GNOME/evince.git#commit=$_commit")
21 sha256sums=('SKIP')
23 pkgver() {
24   cd $pkgname
25   git describe --tags | sed 's/-/+/g'
28 prepare() {
29   cd $pkgname
31   
32 build() {
33   arch-meson $pkgname build -D ps=enabled
34   meson compile -C build
37 check() {
38   meson test -C build --print-errorlogs
41 package() {
42   meson install -C build --destdir "$pkgdir"