archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gjs / repos / extra-x86_64 / PKGBUILD
blob6019ae6a1e2c3ffc533ef21f0f401a79623d0595
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gjs
5 pkgver=1.70.0
6 pkgrel=1
7 epoch=2
8 pkgdesc="Javascript Bindings for GNOME"
9 url="https://wiki.gnome.org/Projects/Gjs"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(cairo gobject-introspection-runtime js78 dconf readline)
13 makedepends=(gobject-introspection git meson dbus)
14 checkdepends=(valgrind xorg-server-xvfb gtk3 gtk4)
15 provides=(libgjs.so)
16 _commit=da5d5fe74469c799de80117758d79ad694d1116a  # tags/1.70.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build \
31     --buildtype release \
32     -D installed_tests=false \
33     -D profiler=disabled
34   meson compile -C build
37 check() {
38   xvfb-run -s '-nolisten local' \
39     meson test -C build --print-errorlogs
42 package() {
43   depends+=(libreadline.so)
44   meson install -C build --destdir "$pkgdir"