1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Roman Kyrylych <roman@archlinux.org>
5 pkgname=gnome-bluetooth
8 pkgdesc="The GNOME Bluetooth Subsystem"
9 url="https://wiki.gnome.org/Projects/GnomeBluetooth"
12 depends=(gtk3 libnotify bluez libcanberra systemd pulseaudio-bluetooth)
13 makedepends=(gobject-introspection gtk-doc docbook-xsl git meson)
14 checkdepends=(python-dbusmock)
15 provides=(libgnome-bluetooth.so)
16 _commit=736eadbfb693d9594371470ad83370d327df6f74 # tags/3.34.5^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-bluetooth.git#commit=$_commit")
22 git describe --tags | sed 's/^GNOMEBT_V_//;s/_fixed//;s/_/./g;s/-/+/g'
30 arch-meson $pkgname build -D gtk_doc=true -D icon_update=false
31 meson compile -C build
35 meson test -C build --print-errorlogs
39 meson install -C build --destdir "$pkgdir"