archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-bluetooth / trunk / PKGBUILD
blobb7f6c102cf705dc1b8423014eadef28b329e8716
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Roman Kyrylych <roman@archlinux.org>
5 pkgname=gnome-bluetooth
6 pkgver=3.34.5
7 pkgrel=2
8 pkgdesc="The GNOME Bluetooth Subsystem"
9 url="https://wiki.gnome.org/Projects/GnomeBluetooth"
10 arch=(x86_64)
11 license=(GPL LGPL)
12 depends=(gtk3 libnotify bluez libcanberra systemd pulseaudio-bluetooth)
13 makedepends=(gobject-introspection gtk-doc docbook-xsl git meson)
14 checkdepends=(python-dbusmock)
15 provides=(libgnome-bluetooth.so)
16 _commit=736eadbfb693d9594371470ad83370d327df6f74  # tags/3.34.5^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-bluetooth.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/^GNOMEBT_V_//;s/_fixed//;s/_/./g;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build -D gtk_doc=true -D icon_update=false
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 et: