1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Multimedia graph framework - core"
8 url="https://gstreamer.freedesktop.org/"
11 depends=(libxml2 glib2 libunwind libcap libelf python)
12 makedepends=(gobject-introspection git valgrind bash-completion meson gmp gsl gtk3)
13 _commit=71c213f99ad5c8fc8f36a26238483f2bdf7d846a # tags/1.18.5^0
14 install=gstreamer.install
15 source=("git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git#commit=$_commit")
20 git describe --tags | sed 's/-/+/g'
28 arch-meson $pkgname build \
30 -D ptp-helper-permissions=capabilities \
32 -D gobject-cast-checks=disabled \
33 -D package-name="GStreamer (Arch Linux)" \
34 -D package-origin="https://www.archlinux.org/"
35 meson compile -C build
39 meson test -C build --print-errorlogs
43 meson install -C build --destdir "$pkgdir"