archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gstreamer / repos / extra-x86_64 / PKGBUILD
blob5498a3ad95a0ba0575dd01295186b3fd891ac5d5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gstreamer
5 pkgver=1.18.5
6 pkgrel=1
7 pkgdesc="Multimedia graph framework - core"
8 url="https://gstreamer.freedesktop.org/"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(libxml2 glib2 libunwind libcap libelf python)
12 makedepends=(gobject-introspection git valgrind bash-completion meson gmp gsl gtk3)
13 _commit=71c213f99ad5c8fc8f36a26238483f2bdf7d846a  # tags/1.18.5^0
14 install=gstreamer.install
15 source=("git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build \
29     -D doc=disabled \
30     -D ptp-helper-permissions=capabilities \
31     -D dbghelp=disabled \
32     -D gobject-cast-checks=disabled \
33     -D package-name="GStreamer (Arch Linux)" \
34     -D package-origin="https://www.archlinux.org/"
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package() {
43   meson install -C build --destdir "$pkgdir"