archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gthumb / trunk / PKGBUILD
blob17c59ba67eb151a05c09409dfc2b1f6e243b528f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias@justdreams.de>
5 pkgname=gthumb
6 pkgver=3.12.0
7 pkgrel=1
8 pkgdesc="Image browser and viewer for the GNOME Desktop"
9 url="https://wiki.gnome.org/Apps/gthumb"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(dconf librsvg clutter-gtk gst-plugins-base-libs gsettings-desktop-schemas libwebp
13          libsecret libsoup webkit2gtk json-glib gst-plugin-gtk libjxl libheif)
14 makedepends=(libchamplain exiv2 brasero libraw liboauth docbook-xsl yelp-tools meson git)
15 optdepends=('libraw: read RAW files'
16             'exiv2: metadata support'
17             'libchamplain: map viewer'
18             'brasero: burn discs'
19             'liboauth: web albums')
20 _commit=1ab909b4754ae3f48d41ee466ca3f4ed5e732785  # tags/3.12.0^0
21 source=("git+https://gitlab.gnome.org/GNOME/gthumb.git#commit=$_commit")
22 sha256sums=('SKIP')
24 pkgver() {
25   cd $pkgname
26   git describe --tags | sed 's/-/+/g'
29 prepare() {
30   cd $pkgname
33 build() {
34   arch-meson $pkgname build -D libchamplain=true
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package() {
43   meson install -C build --destdir "$pkgdir"