archrelease: copy trunk to extra-x86_64
[arch-packages.git] / hunspell / trunk / PKGBUILD
blobd738b95418bf9ef1c539d00d4cc8c911ee6ac65f
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
4 pkgname=hunspell
5 pkgver=1.7.0
6 pkgrel=3
7 pkgdesc="Spell checker and morphological analyzer library and program"
8 arch=('x86_64')
9 url="https://hunspell.github.io/"
10 license=('GPL' 'LGPL' 'MPL')
11 depends=('gcc-libs' 'readline')
12 optdepends=('perl: for ispellaff2myspell')
13 source=($pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz)
14 sha256sums=('bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a')
16 prepare() {
17   cd hunspell-$pkgver
18   autoreconf -vfi
21 build() {
22   cd hunspell-$pkgver
23   ./configure --prefix=/usr --disable-static \
24         --with-ui --with-readline # --with-experimental breaks build in this release
25   make
28 check() {
29   cd hunspell-$pkgver
30   make check
33 package() {
34   cd hunspell-$pkgver
35   make DESTDIR="$pkgdir" install
36   
37   # add generic hunspell.so for development and projects not using pkgconfig flags - FS#30592
38   pushd "$pkgdir"/usr/lib
39   ln -s libhunspell-?.?.so libhunspell.so
40   popd