archrelease: copy trunk to extra-x86_64
[arch-packages.git] / layer-shell-qt / trunk / PKGBUILD
blob815efb9045a8b72f1d7e2564f5a42d9e4ba84924
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=layer-shell-qt
4 pkgver=5.23.4
5 pkgrel=1
6 pkgdesc='Qt component to allow applications to make use of the Wayland wl-layer-shell protocol'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(GPL LGPL)
10 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
11 depends=(qt5-wayland)
12 makedepends=(extra-cmake-modules wayland-protocols)
13 groups=(plasma)
14 sha256sums=('53c4106dbba50ace8c4c0e1e2739a1b190797e2b0a48725b88bdcbd1f9d1e428'
15             'SKIP')
16 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
17               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
18               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
19               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
21 build() {
22   cmake -B build -S $pkgname-$pkgver
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build